Автор Тема: Как мне обновить версию PHP для моего сайта WordPress?  (Прочитано 52 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Aurum

  • Администратор
  • *****
  • Сообщений: 29
  • Карма: +5/-0
  • на светлой стороне силы
В этом руководстве мы рассмотрим, как вы можете безопасно обновить PHP до последней версии, не нарушая работы вашего сайта на WordPress.
Примечание. Как правило, версия PHP имеет трехлетний жизненный цикл, после которого ее не следует использовать. Для получения дополнительной информации о том, почему важно обновлять версии, вы можете ознакомившись с руководством: Почему мне нужно обновить PHP?


Шаг 1 - Проверьте текущую версию PHP.
Во-первых, вам нужно проверить, какую версию PHP вы сейчас используете. Войдите в панель управления cPanel > раздел Программное обеспечение > Выбор версии PHP> Текущая версия PHP здесь будет указана версия php которая сейчас используется.
Если вы используете PHP версии 7.2 или выше, то у вас все хорошо. Если у вас PHP 7.0 или 5.6, вам нужно обновить. Пожалуйста, перейдите к шагу 2.



Шаг 2 - Обновите WordPress до последней версии.
Убедитесь, что ядро ​​WordPress и все Ваши темы, плагины обновлены до необходимой версии.
1. Войдите в свою административную панель WordPress.
2. Нажмите Панель инструментов > Обновления.
3. Убедитесь, что у вас установлена ​​последняя версия WordPress, и все плагины, и темы обновлены.
4. Обновите при необходимости.



Шаг 3 - Установите плагин «Проверки совместимости PHP».
1. Перейти к плагинам в вашем WordPress.
2. Нажмите Добавить плагин в верхней части экрана.
3. Найдите PHP Compatibility Checker в поле поиска.
4. Установите плагин и активируйте его.



Шаг 4 - Запустите сканирование и устраните потенциальные проблемы.
Примечание: Если вы используете плагин кеширования , вам необходимо временно деактивировать его при запуске сканирования. Вы можете сделать это из раздела плагинов.
1. Зайдите в Инструменты в админ панели WordPress и выберите PHP Compatibility Checker.
2. Выберите PHP 7.3, установите флажок «Сканировать все плагины и темы» и нажмите «Сканировать сайт».
3. Подождите, пока сканирование не закончится.
4. Вы можете получить три результата:
Compatible - все хорошо!
Warning - это работает, но может вызвать проблемы со следующей версией PHP.
Error - скорее всего, вызовет проблемы после обновления.
5. Исправьте плагины или темы, которые выдают ошибки; например обновив до более новой версии, либо найдите альтернативный плагин с той же функциональностью.
Совет: мы рекомендуем использовать только те плагины, которые регулярно обновляются и совместимы с последней версией WordPress.



Шаг 5 - Обновите PHP до последней версии
Теперь вы готовы обновить PHP. Мы также рекомендуем включать сообщения об ошибках PHP. Если есть проблема с кодом, сообщения об ошибках сообщит вам, что его вызывает и что может вызывать конфликт в работе сайта.
1. Вернитесь к cPanel > раздел Программное обеспечение > Выбор версии PHP
2. Настройки
3. Установите сообщения об ошибках на Вкл.
4. Текущая версия PHP, пожалуйста, измените версию на 7.3
Совет: Вы также можете обновить PHP до «последней стабильной версии». Поддерживаемые стабильные версии php



Шаг 6 - Убедитесь, что ваш сайт работает должным образом.
Если у вас есть сайт с большим количеством посетителей, это может занять некоторое время. Вот почему мы рекомендуем проверить ваш сайт несколько раз в течение следующих 24 часов.
Если ваш сайт работает не так, как ожидалось, то наиболее вероятным виновником является плагин или тема. Для выявления проблемы:
1. Временно переключитесь на стандартную тему WordPress, например, «Twenty Seventeen».
2. Деактивируйте все установленные плагины.
3. Снова включайте все плагины и темы, одну за другой, проверяя каждый раз, как работает ваш сайт.
Если вы не можете получить доступ к панели администратора WordPress, вы можете отключить плагины и темы при помощи Диспетчера задач в панели управления cPanel.
Вы всегда можете связаться с нами для получения дополнительной информации. Наша служба поддержки может помочь вам выяснить, что не так, однако имейте в виду, что мы не можем исправить код за вас. Это вам нужно сделать самостоятельно.


« Последнее редактирование: 27 Май 2020, 09:27:09 am от Eugenious »
Пройду курсы гадалок для определения исходного кода по скриншоту.